Error when internet on. Django 1.9+Helicon Zoo on WS 2008R2

Repository of web frameworks and applications for Microsoft IIS.
User avatar
Posts: 2
Joined: 22 Sep 2016, 07:03

Error when internet on. Django 1.9+Helicon Zoo on WS 2008R2

22 Sep 2016, 07:25

IIS 7.5 on WS 2008R2 on Virtual Machine. I have two interfaces - one to local network, one to internet via NAT. If working only local netwokr interface, all working fine, but when I enable internet I'm get next errors:

408 Request Timeout
Helicon Zoo module has caught up an error. Please see the details below.
Worker Status
Request timed out.The worker process did not respond within the required timeout period. You may increase timeout by setting WORKER_REQUEST_TIMEOUT environment variable in web.config file to the required amount of seconds.

Windows error
The I/O operation has been aborted because of either a thread exit or an application request. (ERROR CODE: 995)
Internal module error

message: Application I/O Error.
type: ZooException
file: App\Jobs\JobBase.cpp
line: 520
version: 3.1.98.538

STDERR
Empty stderr

Environment variables
ALLUSERSPROFILE C:\ProgramData
APPDATA C:\Windows\system32\config\systemprofile\AppData\Roaming
APPL_ID
APPL_PHYSICAL_PATH C:\back
APPL_PHYSICAL_SHORT_PATH C:\back
APPL_VIRTUAL_PATH
APP_POOL_CONFIG C:\inetpub\temp\apppools\back1\back1.config
APP_POOL_ID back1
COMMONPROGRAMFILES C:\Program Files\Common Files
COMMONPROGRAMFILES(X86) C:\Program Files (x86)\Common Files
COMMONPROGRAMW6432 C:\Program Files\Common Files
COMPUTERNAME IISSERVER
COMSPEC C:\Windows\system32\cmd.exe
CONSOLE_URL console
DEPLOY_FILE deploy.py
DEPLOY_LOG deploy.log
DJANGO_SETTINGS_MODULE back.settings
ERROR_LOG_DIR log
FP_NO_HOST_CHECK NO
HOST 127.0.0.1
IIS_BINDNGS https=*:443:
INSTANCE_ID 2
LOCALAPPDATA C:\Windows\system32\config\systemprofile\AppData\Local
NUMBER_OF_PROCESSORS 1
OS Windows_NT
PATH C:\back\venv\Scripts;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Microsoft\Web Platform Installer\;C:\Program Files\PostgreSQL\pg95\bin
PATHEXT .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
PROCESSOR_ARCHITECTURE AMD64
PROCESSOR_IDENTIFIER Intel64 Family 6 Model 60 Stepping 3, GenuineIntel
PROCESSOR_LEVEL 6
PROCESSOR_REVISION 3c03
PROGRAMDATA C:\ProgramData
PROGRAMFILES C:\Program Files
PROGRAMFILES(X86) C:\Program Files (x86)
PROGRAMW6432 C:\Program Files
PSMODULEPATH C:\Windows\system32\WindowsPowerShell\v1.0\Modules PUBLIC C:\Users\Public
PYTHONPATH C:\back\venv\lib\site-packages;C:\back\venv\lib;C:\back;C:\back\back
SITE_NAME BACK
SITE_PHYSICAL_PATH C:\back
SYSTEMDRIVE C:
SYSTEMROOT C:\Windows
TEMP C:\Windows\TEMP
TMP C:\Windows\TEMP
USERDOMAIN COMP
USERNAME IISSERVER$
USERPROFILE C:\Windows\system32\config\systemprofile
VIRTUAL_ENV C:\back\venv
WINDIR C:\Windows
WINDOWS_TRACING_FLAGS 3
WINDOWS_TRACING_LOGFILE C:\BVTBin\Tests\installpackage\csilogfile.log
WSGI_APP wsgi.application
Helicon Zoo engine settings
appName python.project
appFullPath C:\python27\python.exe
appDirectory C:\back
appArguments C:\Zoo\Workers\python\zoofcgi.py
deployArguments
transportName NamedPipe
protocol fastcgi
scriptProcessor python.2.7.wsgi
errorLogDir C:\back\log
postBufferDir
watchFileChangesMask
host 127.0.0.1
port %PORT%
proxyPass
minInstances 1
maxInstances 1
minRequestsPerWorker 3
maxRequestsPerWorker 15
portLower 49152
portUpper 65535
workerRequestTimeout 30
timeLimit 0
postBuffer 1024
memoryLimit 0
gracefulShutdownTimeout 30
Web.config variables
APPL_ID
APPL_PHYSICAL_PATH C:\back
APPL_PHYSICAL_SHORT_PATH C:\back
APPL_VIRTUAL_PATH
CONSOLE_URL console
DEPLOY_FILE deploy.py
DEPLOY_LOG deploy.log
DJANGO_SETTINGS_MODULE back.settings
ERROR_LOG_DIR log
HOST 127.0.0.1
IIS_BINDNGS https=*:443:
INSTANCE_ID 2
PATH C:\back\venv\Scripts;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Microsoft\Web Platform Installer\;C:\Program Files\PostgreSQL\pg95\bin
PYTHONPATH C:\back\venv\lib\site-packages;C:\back\venv\lib;C:\back;C:\back\back
SITE_NAME BACK
SITE_PHYSICAL_PATH C:\back
VIRTUAL_ENV C:\back\venv
WSGI_APP wsgi.application
Request variables
There are no variables


ZooError-0.log
[22.09.2016 12:58:48.022168] [v 3.1.98.538] [tid 0x000006bc] [sev 2] # 29314880 Application has been started
[22.09.2016 12:59:18.040454] [v 3.1.98.538] [tid 0x00000b9c] [sev 2] WorkersManager - Ping Failed
[22.09.2016 12:59:48.057740] [v 3.1.98.538] [tid 0x00000b9c] [sev 2] WorkersManager - Worker closed. #1

web.config

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
<system.webServer>
<heliconZoo>
<clear />
<application name="python.project" >
<environmentVariables>
<add name="VIRTUAL_ENV" value="%APPL_PHYSICAL_PATH%\venv" />
<add name="PATH" value="%APPL_PHYSICAL_PATH%\venv\Scripts;%PATH%" />
<add name="PYTHONPATH" value="%APPL_PHYSICAL_PATH%\venv\lib\site-packages;%APPL_PHYSICAL_PATH%\venv\lib;%APPL_PHYSICAL_PATH%;%APPL_PHYSICAL_PATH%\back" />

<add name="WSGI_APP" value="wsgi.application" />

<!-- django project -->
<add name="DJANGO_SETTINGS_MODULE" value="back.settings" />

<!-- application deployment -->
<add name="DEPLOY_FILE" value="deploy.py" />
<add name="DEPLOY_LOG" value="deploy.log" />

<!-- logging -->
<add name="ERROR_LOG_DIR" value="log" />


</environmentVariables>
</application>
</heliconZoo>

<handlers>

<remove name="python.project#x86" />
<remove name="python.project#x64" />

<!-- Django or WSGI application over fastcgi -->
<add name="python.project#x86" scriptProcessor="python.2.7.wsgi" path="*" verb="*" modules="HeliconZoo_x86" preCondition="bitness32" resourceType="Unspecified" requireAccess="Script" />
<add name="python.project#x64" scriptProcessor="python.2.7.wsgi" path="*" verb="*" modules="HeliconZoo_x64" preCondition="bitness64" resourceType="Unspecified" requireAccess="Script" />

<!-- HTTP backend (Tornado) over http -->
<!--
<add name="python.project#x86" scriptProcessor="python.2.7.http" path="*" verb="*" modules="HeliconZoo_x86" preCondition="bitness32" resourceType="Unspecified" requireAccess="Script" />
<add name="python.project#x64" scriptProcessor="python.2.7.http" path="*" verb="*" modules="HeliconZoo_x64" preCondition="bitness64" resourceType="Unspecified" requireAccess="Script" />
-->

<!-- HTTP backend (Twisted) over http -->
<!--
<add name="python.project#x86" scriptProcessor="python.2.7.twisted" path="*" verb="*" modules="HeliconZoo_x86" preCondition="bitness32" resourceType="Unspecified" requireAccess="Script" />
<add name="python.project#x64" scriptProcessor="python.2.7.twisted" path="*" verb="*" modules="HeliconZoo_x64" preCondition="bitness64" resourceType="Unspecified" requireAccess="Script" />
-->
</handlers>

</system.webServer>
</configuration>


Sometimes, the site admits, but half of the Ajax methods did not work. How to fix it? Thanks :( :( :(

User avatar
Posts: 2
Joined: 22 Sep 2016, 07:03

Re: Error when internet on. Django 1.9+Helicon Zoo on WS 200

22 Sep 2016, 08:15

Sometimes appears next error:
Windows error
The pipe is being closed. (ERROR CODE: 232)

User avatar
Posts: 402
Joined: 06 Mar 2012, 11:59

Re: Error when internet on. Django 1.9+Helicon Zoo on WS 200

22 Sep 2016, 08:36

Hello.


Error from Zoo indicates the backend application did not respond in time after Zoo has started a backend worker. Since you find that internet connection is somehow involved it seems like your application is trying to download something from the internet, or simply hangs on it. Unfortunately, there is no any essential information in STDERR, so your application did not return any errors or even debug messages. It simply hangs and Zoo kills it after a timeout. Please try to troubleshoot your on that machine application without Zoo first, maybe you will stumble on the same error so you could find its cause.

Return to Helicon Zoo

Who is online

Users browsing this forum: No registered users and 5 guests